Internet Banking - Transaction History Unavailable
Incident Report for BNZ Internet Banking
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 20:50 NZDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2020 - 20:48 NZDT
Identified
Customers are unable to access account transaction history

Our Support team are investigating this issue. Update to follow.
Posted Feb 03, 2020 - 20:29 NZDT
This incident affected: Internet Banking, Internet Banking for Business, Mobile Internet Banking (iOS & Android), and Mobile Business Banking (iOS & Android).