SecurePay ecommerce transactions for non-BNZ Visa Cards

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 21:03 NZST

Update

We are continuing to investigate this issue.
Posted Apr 15, 2025 - 15:54 NZST

Investigating

We are currently investigating this issue.
Posted Apr 15, 2025 - 15:48 NZST
This incident affected: Business (Accepting card payments).