Outage affecting transaction history in Internet Banking
Incident Report for BNZ Internet Banking
Resolved
Customers are now able to see transaction history in the following BNZ Internet Banking Services:
- Internet Banking for Business
- Internet Banking
- Mobile Banking (iOS & Android)
- Mobile Business Banking (iOS & Android)
Posted Jun 27, 2022 - 12:00 NZST
Identified
Some customers are currently unable to see transaction history in the following BNZ Internet Banking Services:
- Internet Banking for Business
- Internet Banking
- Mobile Banking (iOS & Android)
- Mobile Business Banking (iOS & Android)

Our Support team are investigating this issue. Update to follow.
Posted Jun 27, 2022 - 10:04 NZST
This incident affected: Internet Banking, Internet Banking for Business, Mobile Internet Banking (iOS & Android), and Mobile Business Banking (iOS & Android).