Some customers are unable to view credit card balances, today's transactions, and instance balances.

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted Jul 12, 2026 - 18:20 NZST

Update

We are continuing to investigate this issue.
Posted Jul 12, 2026 - 11:33 NZST

Update

We are continuing to investigate this issue.
Posted Jul 12, 2026 - 09:52 NZST

Investigating

Some customers are unable to view credit card balances, today's transactions, and instance balances.
We’re investigating the issue and will provide an update when we have more information.
Posted Jul 12, 2026 - 09:47 NZST
This incident affected: Internet Banking, Business Banking, BNZ app (iOS & Android), and BNZ Business app (iOS & Android).