Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2026 - 22:00 NZDT
Scheduled
Due to planned maintenance, Notification services will be unavailable on Sunday, 8 March from 10pm until 11:30pm Sunday, 8 March. This will mean you will not receive Mobile or email notifications during this period.
Posted Mar 03, 2026 - 11:07 NZDT
This scheduled maintenance affected: Internet Banking, Business Banking, BNZ app (iOS & Android), and BNZ Business app (iOS & Android).