We are currently experiencing issues with transaction history in Mobile and Internet Banking. We apologise for any inconvenience.

Incident Report for BNZ Internet Banking

Resolved

Customers can now view their transaction history in all online channels. Thank you for your patience.
Posted Jun 05, 2025 - 13:16 NZST

Update

We are continuing to investigate this issue. Business banking, CFS, and Bankfeeds API are also impacted.
Posted Jun 05, 2025 - 12:11 NZST

Update

We are continuing to investigate this issue.
Posted Jun 05, 2025 - 12:03 NZST

Investigating

We’re investigating the issue and will provide an update when we have more information.
Posted Jun 05, 2025 - 12:02 NZST
This incident affected: Internet Banking, Business Banking, BNZ app (iOS & Android), BNZ Business app (iOS & Android), Client Fund Services and BNZ Public API status (BankFeeds API).