Some customers are unable to do file uploads in Business Banking

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 22:16 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 22:04 NZST

Investigating

We’re investigating the issue and will provide an update when we have more information.
Posted Aug 03, 2026 - 20:56 NZST
This incident affected: Business Banking.