Internet Banking for Business - Login Issues

Incident Report for BNZ Internet Banking

Resolved

The issue has been resolved.
Posted Aug 31, 2018 - 11:28 NZST

Identified

This issue is now affecting all Internet Banking for Business customers. Support teams are working a fix.
Posted Aug 31, 2018 - 10:49 NZST

Investigating

Some customers are unable to log in to Internet Banking for Business

Our Support team are investigating this issue. Update to follow.
Posted Aug 31, 2018 - 10:38 NZST
This incident affected: Business Banking and BNZ Business app (iOS & Android).