Mobile Internet Banking unavailable

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 21:46 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2026 - 18:57 NZST

Update

The following online banking channels are unavailable:

- BNZ app (iOS & Android)
- BNZ Business app (iOS & Android)

We’re investigating the issue and will provide an update when we have more information.
Posted Jun 19, 2026 - 18:37 NZST

Investigating

We are currently investigating this issue.
Posted Jun 19, 2026 - 18:27 NZST
This incident affected: BNZ app (iOS & Android) and BNZ Business app (iOS & Android).