BNZ Internet Banking - Under Maintenance
Incident Report for BNZ Internet Banking
Resolved
Maintenance complete
Posted Nov 14, 2019 - 01:45 NZDT
Investigating
Service is currently under maintenance expected to return 1:00AM
Posted Nov 14, 2019 - 00:10 NZDT
This incident affected: Internet Banking, Internet Banking for Business, Mobile Internet Banking (iOS & Android), Mobile Business Banking (iOS & Android), and Client Fund Services.