BNZ Partners Centre Booking Issues

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:24 NZST

Investigating

We are currently experiencing technical issues with our Partners Centre room booking system which is temporarily unavailable. We apologise for any inconvenience this may cause.
Posted Aug 27, 2026 - 12:54 NZST
This incident affected: Contact Centre.