Duplicated transactions for internet banking

Incident Report for BNZ Internet Banking

Resolved

This incident has been resolved.
Posted May 22, 2026 - 07:53 NZST

Update

We are continuing to investigate this issue.
Posted May 22, 2026 - 07:14 NZST

Investigating

We are currently experiencing issues that may mean some transactions are duplicated, we are investigating.
Posted May 22, 2026 - 07:09 NZST
This incident affected: Internet Banking, Business Banking, BNZ app (iOS & Android), BNZ Business app (iOS & Android), and Bankfeeds File Transfer.