Term Deposits temporarily unavailable

Incident Report for BNZ Internet Banking

Resolved

Customers can now access Term Deposits. Thank you for your patience.
Posted Nov 28, 2023 - 13:30 NZDT

Investigating

We are currently investigating this issue.
Posted Nov 28, 2023 - 13:19 NZDT