Credit card details are currently unavailable
Incident Report for BNZ Internet Banking
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 18:43 NZST
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 18:39 NZST
Investigating
We’re investigating the issue and will provide an update when we have more information.
Posted Jul 19, 2024 - 16:57 NZST
This incident affected: Internet Banking, Business Banking, BNZ app (iOS & Android), and BNZ Business app (iOS & Android).