Trade Finance Online is currently unavailable
Incident Report for BNZ Internet Banking
Resolved
This incident has been resolved.

The Trade Finance Online application within Internet Banking for Business is available again.
Posted Aug 16, 2022 - 12:27 NZST
Update
We are continuing to investigate this issue.

The Trade Finance Online application within Internet Banking for Business remains unavailable.

All other Internet Banking for Business functionality is still available.
Posted Aug 16, 2022 - 11:12 NZST
Investigating
The Trade Finance Online application within Internet Banking for Business is currently unavailable.

All other Internet Banking for Business functionality is still available.

Our support teams are investigating. We apologise for this inconvenience.
Posted Aug 16, 2022 - 09:53 NZST
This incident affected: Business Banking.