Some customers are unable to log in

Incident Report for BNZ Internet Banking

Resolved

Customers can now log in. Thank you for your patience.
Posted Apr 12, 2025 - 10:23 NZST

Investigating

We’re investigating the issue and will provide an update when we have more information.
Posted Apr 12, 2025 - 09:27 NZST
This incident affected: Internet Banking, Business Banking, BNZ app (iOS & Android), and BNZ Business app (iOS & Android).