Transaction history currently unavailable.
Incident Report for BNZ Internet Banking
Resolved
Transaction history is now available for all Internet Banking applications.
Posted Feb 21, 2020 - 22:30 NZDT
Identified
Transaction history is currently unavailable, we apologise for the inconvenience.
Posted Feb 21, 2020 - 22:22 NZDT
This incident affected: Internet Banking, Internet Banking for Business, Mobile Internet Banking (iOS & Android), Mobile Business Banking (iOS & Android), and Client Fund Services.